Oracle Banner with Java 7

From AFP548 Wiki
Jump to: navigation, search

Users working in Oracle's Banner with Java 7 installed will get the following error: "FRM-92025 Oracle Jinitiator version too low". Oracle has not released a version of Banner compatible with Java 7 yet. The manual GUI solution was found here, but to avoid calls to the HelpDesk, it can be automated using this shell script:

#!/bin/sh
sed -i -e 's/deployment.javaws.jre.0.args=/deployment.javaws.jre.0.args=-Djava.vendor=\"Sun Microsystems Inc."/g' ~/Library/Application\ Support/Oracle/Java/Deployment/deployment.properties

Side Notes[edit]

  • Any open browsers will need to be quit and re-opened before the changes take affect.
  • Since this is in the home directory, the user doesn't need to be admin to run it.
  • This will have to be run per-user, per-machine.